Resources
    Example Configurations fo ...
    20 January 08

    Example Configurations for PPP over Ethernet (PPPoE)

    Posted byINE
    facebooktwitterlinkedin
    news-featured

    Below are a couple example configurations for PPPoE. Note that you can run into MTU issues when trying to use OSPF over PPPoE. This can easily be resolved by using the "ip ospf mtu-ignore" command as the dialer interface's MTU is 1492 while the virtual-template's (virtual-access) MTU is 1500.

    *** Client ***
    interface Ethernet0/0
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Dialer1
    ip address 142.1.35.5 255.255.255.0
    encapsulation ppp
    dialer-pool 1
    dialer persistent

    *** Server ***

    vpdn enable
    !
    vpdn-group CISCO
    accept-dialin
    protocol pppoe
    virtual-template 1
    !
    interface Ethernet0/0
    pppoe enable
    !
    interface Virtual-Template1
    ip address 142.1.35.3 255.255.255.0

    The next example is using DHCP to assign the client their IP address:

    *** Client ***
    

    interface Ethernet0/1
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Dialer1
    ip address dhcp
    encapsulation ppp
    dialer pool 1
    dialer persistent

    *** Server ***

    ip dhcp excluded-address 191.1.45.1 190.12.45.3
    !
    ip dhcp pool MYPOOL
    network 191.1.45.0 255.255.255.0
    !
    vpdn enable
    !
    vpdn-group CISCO
    accept-dialin
    protocol pppoe
    virtual-template 1
    !
    interface Ethernet0/0
    pppoe enable
    !
    interface Virtual-Template1
    ip address 191.1.45.5 255.255.255.0
    peer default ip address dhcp-pool MYPOOL

    © 2024 INE. All Rights Reserved. All logos, trademarks and registered trademarks are the property of their respective owners.
    instagram Logofacebook Logotwitter Logolinkedin Logoyoutube Logo